Frequently Asked Questions

Here you will find answers to the most common questions we get. If you can't find your answer here, you haven't looked carefully enough, or we just haven't added it yet. In that case, just send the question to us (Contact Softube Support) and we'll answer as fast as we can.

Listing answers tagged "Compatibility"

Showing items 1–10 of 11.

System Requirements
These are the system requirements for Softube plug-ins. Read more...
What plugin formats are available?
VST/VST3, AU, RTAS and AAX-Native/DSP. Read more...
Do your products work with an iLok Generation 1?
No, From June 1st 2018, you will no longer be able to use iLok 1 to authorise your Softube plug-ins. What is iLok? Read more...
Will you make product x for the AAX DSP platforms?
Almost all our plug-ins are available for the Pro Tools HDX platform (AAX DSP). Read more...
Do your plug-ins work with host X?
If it is compatible with Native VST/AU/AAX and on Mac or Windows it should work. Download the demo to make sure. Read more...
Help! The license says native? Will I also get the AAX DSP version?
Yes, all available AAX DSP versions are included in the Native license. Read more...
« PREVIOUS 1 2 NEXT »
FBQ