All products require at least Intel Core/AMD Athlon 64 or better processor. Please see the System Requirements for more information. If you have an older system, go to the Legacy Installers page.

Need help?
Please see the Frequently Asked Questions, or more specifically "How do I install Softube plug-ins?".